Is my device compatible with Echo?

Echo app and Echo Tag are compatible with both iOS and Android devices!

## iOS

Tile is compatible with the following iOS devices running iOS 10 and up:

* iPhone 5s or newer
* iPad 3rd Gen or newer
* iPad Mini 2 or newer
* iPad Pro or newer

New iOS devices will be supported as they become available, as long as they have Bluetooth 4.0 support.

## Android

What Android phones will Echo officially work with? As long as the devices listed below are running Android 6.0 or newer, they are officially compatible with Echo!

* Samsung Galaxy (S6 or newer)
* Huawei P10 or newer

There are many different Android devices on the market. If your Android device is not on this official compatibility list, that means we have not officially tested Echo with your device type. There is a good chance Echo is compatible as long as your device is running Android 6.0 or newer and has Bluetooth 4.0, but we cannot guarantee the same level of technical support in troubleshooting scenarios. We will do our best to expand the list to the best of our efforts.

*If you are running iOS 9 or older and Android 5.0 or older, the latest version of our app that you will be able to download is 2.27.

## What devices will not work with Echo?

Any devices that do not have Bluetooth 4.0 or BLE, will not work. These devices do not have the hardware to communicate with our Echo pp or Echo Tag.